RenalWEB Home Page    renalweb.groupee.net    RenalWEB Discussion Forums  Hop To Forum Categories  Dialysis Technician Forums  Hop To Forums  Dialysis Technical Forum    brand new level detector wont calibrate
Go
New
Find
Notify
Tools
Reply
  
brand new level detector wont calibrate
 Login/Join
 
posted
I had a machine that failed a lot of different things. After replacing the blood pump that had an e02 error and recalibrated everything dialysate related to fix the stuck at 12.8 conductivity alarm I was unable to calibrate the level detector. I ordered a new lp450 board and it was waiting for me this morning. I installed it but this brand new board wont calibrate either.

When I move the jumper over to calibrate both lights are on and stay on. I have adjusted the pot at least ten times in both directions. Any ideas or did I end up with a faulty board?
 
Posts: 46 | Registered: 21 November 2016Reply With QuoteReport This Post
<pops>
posted
wealth
have you tried replacing the sensors also check the ribbon cables, be sure to replace the sensors as a matched pair Wink

disclaimer my views and no one else Razzer

ps you sure got a lemon with that machine Mad
 
Reply With QuoteReport This Post
posted Hide Post
Thanks for the suggestion. I'll try that out today as well.

Funny thing is the repair log says that the same machine had a blood pump e02 error on the second month of life. A year later it has happened again. I'll just keep calling them for more parts until they tell me to pick up my new machine. LOL
 
Posts: 46 | Registered: 21 November 2016Reply With QuoteReport This Post
<Guest>
posted
I had the same problem once. The ribbon cable came off in the card cage. That would explain why it still won't calibrate after putting a new board in. Anytime you put the card cage out, you should check every cable. Every time I pull it out, I almost always have a random cable pop off.
 
Reply With QuoteReport This Post
posted Hide Post
low and behold i swapped the sensors on the level detector and now it seems to be happy. passed test 5 times. conductivity is correct. Back to the floor with you!!
 
Posts: 46 | Registered: 21 November 2016Reply With QuoteReport This Post
<Guest>
posted
Yes the sensors haven't been great on these new ones either..
 
Reply With QuoteReport This Post
  Powered by Social Strata  
 

RenalWEB Home Page    renalweb.groupee.net    RenalWEB Discussion Forums  Hop To Forum Categories  Dialysis Technician Forums  Hop To Forums  Dialysis Technical Forum    brand new level detector wont calibrate

Copyright RenalWEB 2017